Skip to main content
CVE-2024-40725VulnerabilityPublished Updated

Apache2: A partial fix for CVE-2024-39884

Affects apache2Source GCVE Database

0

Mentioned vulnerabilities

Not known to be exploited · CVSS 5.3 Medium · fixed in 2.4.41-4ubuntu3.21 : update apache2 when convenient.

Data as of 26 Oct 2026, 14:05 UTC

CVSS 3.1 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
4.4% chance of exploitation in 30 days – higher than 91% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.4.41-4ubuntu3.21, 2.4.52-1ubuntu4.12, 2.4.58-1ubuntu8.4
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 17 Jul 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade the Ubuntu apache2 to 2.4.41-4ubuntu3.21 (package) or 2.4.52-1ubuntu4.12 (package) or 2.4.58-1ubuntu8.4 (package).

Affected software

ProductAffectedFixed in
Ubuntu 24.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.58-1ubuntu8.4?arch=source&distro=nobleOther threatsAffected
  • <2.4.58-1ubuntu8.4
Fixed in
  • 2.4.58-1ubuntu8.4
Ubuntu 22.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.52-1ubuntu4.12?arch=source&distro=jammyOther threatsAffected
  • <2.4.52-1ubuntu4.12
Fixed in
  • 2.4.52-1ubuntu4.12
Ubuntu 20.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.41-4ubuntu3.21?arch=source&distro=focalOther threatsAffected
  • <2.4.41-4ubuntu3.21
Fixed in
  • 2.4.41-4ubuntu3.21
Ubuntu Pro 14.04 LTSapache2pkg:deb/ubuntu/apache2@2.4.7-1ubuntu4.22+esm15?arch=source&distro=esm-infra-legacy/trustyOther threatsAffected
  • 2.4.6-2ubuntu2 – 2.4.7-1ubuntu4.22+esm15
38 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

An official fix is available in Apache HTTP Server version 2.4.62. Users should upgrade to this version to fully remediate the vulnerability. Until upgraded, the partial fix in 2.4.61 does not fully prevent source code disclosure when using legacy content-type based handler configurations.

Description

A partial fix for CVE-2024-39884 in Apache HTTP Server 2.4.61 fails to fully address the issue with legacy content-type based handler configurations such as "AddType". Under certain conditions, this can cause source code disclosure of local content, for example serving PHP scripts as plain text instead of interpreting them. The issue is fixed in Apache HTTP Server version 2.4.62. Users are advised to upgrade to this version to resolve the vulnerability.

References

Community reviews

Loading reviews…