CVE-2026-63667: ApostropheCMS · Arbitrary file read via import-export attachment-name path traversal
Affects @apostrophecms/import-exportSource GCVE Database
Not known to be exploited · CVSS 6.5 Medium : upgrade to 3.6.2 when convenient.
Data as of 3 Nov 2026, 00:30 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 6.5 |
|---|
- Patch
- Available – fixed in 3.6.2
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 17 Aug 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2 Nov 2026.
What to do
Upgrade @apostrophecms/import-export to 3.6.2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npm@apostrophecms/import-export | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in @apostrophecms/import-export version 3.6.2 that fixes this path traversal vulnerability. Users should upgrade to version 3.6.2 or later. The vulnerability requires the module to be installed and registered; sites without this module are not affected. No additional mitigations are indicated by the vendor advisory.
Description
ApostropheCMS's @apostrophecms/import-export module (versions before 3.6.2) contains a path traversal vulnerability that allows authenticated contributors to read arbitrary files on the host system. This occurs because the module constructs file paths from unvalidated JSON metadata fields in an imported archive, enabling traversal outside the intended directory. Files with certain allowed extensions (e.g., txt, csv, pdf) can be read and then served publicly without authentication. The vulnerability requires contributor-level access and is fixed in version 3.6.2.
References
- github.com/apostrophecms/apostrophe/security/advisories/GHSA-79qf-vqgc-7xx3 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-63667 (opens in a new tab)
- github.com/apostrophecms/apostrophe/commit/87cccf44a23d09420875ca8a3765eb3db843836a (opens in a new tab)
- github.com/apostrophecms/apostrophe (opens in a new tab)
- github.com/apostrophecms/apostrophe/discussions/5516 (opens in a new tab)