Skip to main content
VulnerabilityPublished

CVE-2026-103658: aspell security update

Affects aspellSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-103658· Medium 5.9

Not known to be exploited · CVSS 5.9 Medium : upgrade to 0.60.8.1-2.oe2403sp1 when convenient.

Data as of 29 Oct 2026, 10:48 UTC

CVSS 3.1 base score
5.9Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 11% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 0.60.8.1-2.oe2403sp1
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade aspell to 0.60.8.1-2.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1aspellpkg:rpm/openEuler/aspell&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <0.60.8.1-2.oe2403sp1
Fixed in
  • 0.60.8.1-2.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of GNU Aspell is available in 0.60.8.1-2.oe2403sp1 and later. Users and administrators should upgrade to this version or later to remediate these vulnerabilities. No additional mitigation steps are required once the update is applied.

Description

GNU Aspell versions prior to 0.60.8.1-2.oe2403sp1 contain multiple heap-based buffer overflow and out-of-bounds read vulnerabilities in their dictionary loading and decompression components. These flaws allow an attacker to craft malicious dictionary or compressed files that, when loaded or processed by Aspell, can cause heap memory corruption, denial of service, or potentially code execution. The issues are fixed in version 0.60.8.1-2.oe2403sp1 and later.

References

Community reviews

Loading reviews…