Skip to main content
VulnerabilityPublished

CVE-2026-108976: emacs security update

Affects emacsSource GCVE Database

0
Compare

Mentioned vulnerabilities

Authoritative record:CVE-2026-108976· High 7.8

Not known to be exploited · CVSS 7.8 High : upgrade to 29.1-11.oe2403sp1 soon.

Data as of 29 Oct 2026, 10:37 UTC

CVSS 3.1 base score
7.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 29.1-11.oe2403sp1
CVSS:3.1/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.

What to do

Upgrade emacs to 29.1-11.oe2403sp1.

Affected software

ProductAffectedFixed in
openEuler 24.03-LTS-SP1emacspkg:rpm/openEuler/emacs&distro=openEuler-24.03-LTS-SP1Other threatsAffected
  • <29.1-11.oe2403sp1
Fixed in
  • 29.1-11.oe2403sp1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and fixed the vulnerability in GNU Emacs version 29.1-11.oe2403sp1. Users should upgrade to this version or later to remediate the issue. No additional mitigation steps are indicated by the vendor advisory.

Description

GNU Emacs versions before 29.1-11.oe2403sp1 contain a security vulnerability (CVE-2026-108976) that allows OS command injection via a filename. This occurs because the tramp-user-regexp filter has an incomplete list of disallowed inputs, resulting from an incomplete fix of a previous vulnerability (CVE-2026-79992).

References

Community reviews

Loading reviews…