CVE-2025-48370: auth-js Vulnerable to Insecure Path Routing from Malformed User Input
Affects @supabase/auth-jsSource GCVE Database
Not known to be exploited · CVSS 2.7 Low : upgrade to 2.70.0 when convenient.
Data as of 27 Oct 2026, 00:07 UTC
- Patch
- Available – fixed in 2.70.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade @supabase/auth-js to 2.70.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| npm@supabase/auth-js | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
Description
### Impact The library functions `getUserById`, `deleteUser`, `updateUserById`, `listFactors` and `deleteFactor` did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the `userId` are not affected by this. ### Patches Strict value checks have been added to all affected functions. These functions now require that the `userId` and `factorId` parameters MUST be valid UUID (v4). **Patched version:** >= 2.69.1 ### Workarounds Implementations that follow security best practice and validate user controlled inputs, such as the `userId` are not affected by this. It is recommended that users of the auth-js library always follow security best practice and validate all inputs, before passing these to other functions or libraries. ### References https://github.com/supabase/auth-js/pull/1063
References
- github.com/supabase/auth-js/security/advisories/GHSA-8r88-6cj9-9fh5 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-48370 (opens in a new tab)
- github.com/supabase/auth-js/pull/1063 (opens in a new tab)
- github.com/supabase/auth-js/commit/1bcb76e479e51cd9bca2d7732d0bf3199e07a693 (opens in a new tab)
- github.com/supabase/auth-js (opens in a new tab)