CVE-2025-48370: supabase auth-js · Improper Authentication
Affects supabase auth-jsSource CVE Database V5
Not known to be exploited · CVSS 2.7 Low : upgrade to 2.70.0 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.9% chance of exploitation in 30 days – higher than 59% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.70.0
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:L/VA:N/SC:N/SI:N/SA:N/E:UExploitation evidence
Disclosed: evidence found.
CVE published 27 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade supabase auth-js to 2.70.0.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| supabase auth-js | Affected
| Fixed in
|
AI-suggested
Upgrade the auth-js library to version 2.70.0 or later, where this issue has been patched. Implementations that already validate user-supplied UUID inputs are not affected and do not require additional action.
Description
auth-js is an isomorphic Javascript library for Supabase Auth. Prior to version 2.70.0, the library functions getUserById, deleteUser, updateUserById, listFactors and deleteFactor did not require the user supplied values to be valid UUIDs. This could lead to a URL path traversal, resulting in the wrong API function being called. Implementations that follow security best practice and validate user controlled inputs, such as the userId are not affected by this. This issue has been patched in version 2.70.0.