mcp-atlassian · Authlib: is_secure_transport() loopback exemption can be bypassed with a userinfo component, allowing cleartext-HTTP
Affects mcp-atlassianSource GCVE Database
Not known to be exploited · CVSS 2.6 Low : upgrade to 0.23.1_1 when convenient.
Data as of 30 Oct 2026, 08:32 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 2.6 |
|---|
- Patch
- Available – fixed in 0.23.1_1
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp-atlassian to 0.23.1_1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Authlib version 0.23.1_1 that corrects the is_secure_transport() function to properly validate loopback HTTP URLs without being bypassed by userinfo components. Users should upgrade to this fixed version to remediate the vulnerability. No additional mitigation steps are required beyond applying the official fix.
Description
Authlib versions from 0.13 through 1.7.2 contain a vulnerability in the is_secure_transport() function where the loopback exemption for HTTP URLs can be bypassed by including a userinfo component in the URL. This causes the function to incorrectly treat certain cleartext HTTP URLs with non-loopback hosts as secure, violating OAuth 2.0 / OIDC TLS requirements. The flaw affects validation of redirect URIs and authorization server metadata endpoints, potentially allowing an attacker to register or use insecure URLs that bypass TLS enforcement. The severity is low and a fix is available in version 0.23.1_1.
References
- github.com/authlib/authlib/security/advisories/GHSA-jj7h-c3hg-m23x (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-114614 (opens in a new tab)
- github.com/authlib/authlib/commit/95ad1f90acf0c7b9cf2a8f25e6eb3f1135b8dc70 (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.8.0 (opens in a new tab)