CVE-2026-114620: Authlib · Unvalidated request_uri fetch in JWT-secured authorization request (JAR) leading to SSRF
Affects mcp-atlassianSource GCVE Database
Not known to be exploited · CVSS 5.4 Medium : upgrade to 0.23.1_2 when convenient.
Data as of 30 Oct 2026, 08:32 UTC
Thin evidence
One scorer or none| CNA (GitHub_M) | CVSS 3.1 | 5.4 |
|---|
- Patch
- Available – fixed in 0.23.1_2
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 22 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade mcp-atlassian to 0.23.1_2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewmcp-atlassianpkg:brew/mcp-atlassianOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in Authlib version 0.23.1_2 that enforces validation of the request_uri parameter, including consulting the pre-registered allowlist and implementing the controls recommended by RFC 9101 §10.4.1. Users should upgrade to version 0.23.1_2 or later. Until upgraded, deployments should avoid using the documented insecure fetch hook implementation and implement strict validation of request_uri parameters, including allowlist checks and response validation. No other vendor advisory states that no action is required.
Description
Authlib's RFC 9101 (JAR) extension contains an SSRF vulnerability due to unvalidated use of the attacker-controlled request_uri parameter in a pre-authentication context. The extension forwards the request_uri to a fetch hook without enforcing the existing allowlist or other recommended controls, enabling unauthenticated SSRF. This affects versions from 0.11.11 up to but not including 0.23.1_2. A fix is available in version 0.23.1_2.
References
- github.com/authlib/authlib/security/advisories/GHSA-x4rv-c3wx-4cr8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-114620 (opens in a new tab)
- github.com/authlib/authlib/pull/949 (opens in a new tab)
- github.com/authlib/authlib/commit/6563f6f7a8c2f71d2f85ee7511d72a4fbae3acc0 (opens in a new tab)
- github.com/authlib/authlib/commit/891e3f10ae5989176211f8be35dcc7cd40aa92c6 (opens in a new tab)
- github.com/authlib/authlib (opens in a new tab)
- github.com/authlib/authlib/releases/tag/v1.9.0 (opens in a new tab)