Skip to main content
CVE-2026-61536VulnerabilityPublished

Banks: Unsafe importlib.import_module of attacker-controlled Tool.import_path

Affects banksSource GCVE Database

0
Compare
Authoritative record:CVE-2026-61536· High 7.5

Not known to be exploited · CVSS 7.5 High : upgrade to 2.4.3 soon.

Data as of 5 Nov 2026, 18:49 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.4.3
CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Jul 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade banks to 2.4.3.

Affected software

ProductAffectedFixed in
PyPIbanksAffected
  • <2.4.3
Fixed in
  • 2.4.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in banks version 2.4.3. Users should upgrade to version 2.4.3 or later to remediate this vulnerability. The vendor advisory confirms the fix in 2.4.3. No other mitigations are indicated as the vulnerability stems from unsafe import resolution that is corrected by the patch.

Description

The banks library versions prior to 2.4.3 contain a remote code execution vulnerability due to unsafe use of importlib.import_module and getattr on attacker-controlled import_path values in Tool JSON objects parsed from template bodies. This allows an attacker who can influence prompt content to execute arbitrary Python code in the hosting process. The vulnerability is distinct from a prior sandboxing fix and remains exploitable in version 2.4.2. A fix is available in version 2.4.3.

References

Community reviews

Loading reviews…