CVE-2025-54381: BentoML SSRF Vulnerability
Affects bentomlSource GCVE Database
Not known to be exploited · 16% EPSS · CVSS 9.9 Critical : upgrade to 1.4.19 as a priority.
Data as of 27 Oct 2026, 18:11 UTC
- EPSS
- 16.1% chance of exploitation in 30 days – higher than 96% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.4.19
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:LExploitation evidence
Disclosed: evidence found.
CVE published 29 Jul 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade bentoml to 1.4.19.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| PyPIbentoml | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available in BentoML version 1.4.19 that addresses this vulnerability by implementing comprehensive URL validation and network restriction checks to block access to internal/private network ranges, localhost, and cloud metadata endpoints. Users should upgrade to version 1.4.19 or later. Until upgraded, users should be aware that the multipart form data handler lacks validation and the JSON handler performs only weak validation, leaving services exposed to SSRF attacks. No other vendor advisory states 'no action required' or 'already mitigated'.
Description
CVE-2025-54381 is a critical Server-Side Request Forgery (SSRF) vulnerability in BentoML's file upload processing system affecting versions >=1.4.0 <1.4.19. It allows unauthenticated remote attackers to make arbitrary HTTP requests from the server to internal network resources, cloud metadata endpoints, or localhost services due to insufficient validation of URLs in multipart form data and JSON request handlers. The vulnerability arises because the framework automatically treats file-type parameters as vulnerable endpoints, and the multipart handler lacks any URL validation. This can lead to credential theft, internal network reconnaissance, and potential exploitation of internal services. A fix is available in version 1.4.19.
References
- github.com/bentoml/BentoML/security/advisories/GHSA-mrmq-3q62-6cc8 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2025-54381 (opens in a new tab)
- github.com/bentoml/BentoML/commit/534c3584621da4ab954bdc3d814cc66b95ae5fb8 (opens in a new tab)
- github.com/bentoml/BentoML (opens in a new tab)
- github.com/pypa/advisory-database/tree/main/vulns/bentoml/PYSEC-2026-297.yaml (opens in a new tab)
- pypi.org/project/bentoml (opens in a new tab)