Skip to main content
CVE-2026-42864VulnerabilityPublished Updated

Firefighter incident: FireFighter has unauthenticated SSRF

Affects firefighter-incidentSource GCVE Database

0
Authoritative record:CVE-2026-42864· Critical 9.9

Not known to be exploited · CVSS 9.9 Critical : upgrade to 0.0.54 as a priority.

Data as of 27 Oct 2026, 17:29 UTC

CVSS 3.1 base score
9.9Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.0.54
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:L/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 11 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade firefighter-incident to 0.0.54.

Affected software

ProductAffectedFixed in
PyPIfirefighter-incidentAffected
  • <0.0.54
Fixed in
  • 0.0.54

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should upgrade to firefighter-incident version 0.0.54 or later, which enforces Bearer token authentication and validates attachment URLs to prevent SSRF. Until upgrading, mitigation options include restricting ingress access to the vulnerable endpoint to trusted networks, rotating or revoking the Jira API token to block issue creation, and enforcing IMDSv2 with HttpPutResponseHopLimit=1 on EC2/EKS nodes to neutralize the IAM credential theft path. These mitigations block exploitation but do not fix the SSRF itself except for the upgrade.

Description

An unauthenticated Server-Side Request Forgery (SSRF) vulnerability exists in the Firefighter incident project in the POST /api/v2/firefighter/raid/jira_bot endpoint. This endpoint allows unauthenticated users to submit attachments URLs that the server fetches without validation, enabling attackers to coerce the server into fetching arbitrary URLs, including the AWS EC2 metadata service. This can lead to theft of temporary AWS IAM credentials on EC2/EKS deployments that do not enforce IMDSv2. The vulnerability is fixed in version 0.0.54 by enforcing authentication and validating attachment URLs.

References

Community reviews

Loading reviews…