Blender before 4.5.15 and 5.x before 5.2.3 contains a heap buffer overflow vulnerability caused by integer overflow in
Affects blenderSource GCVE Database
Not known to be exploited · CVSS 8.5 High · fixed in 4.5.15 : patch blender soon.
Data as of 5 Nov 2026, 13:02 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.5 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.8 |
| CNA | CVSS 4.0 | 8.5 |
- Patch
- Available – fixed in 4.5.15
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10blenderpkg:deb/ubuntu/blender?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Blender versions 4.5.15 and 5.2.3 and later. Users should upgrade to these versions or later to remediate the vulnerability. No other mitigation guidance is provided.
Description
A heap buffer overflow vulnerability exists in Blender versions before 4.5.15 and 5.x before 5.2.3 due to an integer overflow in the ptcache_data_alloc() function when reading point cache files. An attacker can exploit this by supplying a crafted point cache file with a large totpoint value alongside a .blend file, potentially causing a crash or arbitrary code execution with the privileges of the user running Blender.
References
- ubuntu.com/security/CVE-2026-119718 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-119718 (opens in a new tab)
- projects.blender.org/blender/blender/pulls/164279 (opens in a new tab)
- projects.blender.org/blender/blender/commit/a0c62db3db61803f86e874bc05407890ce4a1e43 (opens in a new tab)
- projects.blender.org/blender/blender/commit/4f8a3270213b1ee67b44fe122ace3debdec3de47 (opens in a new tab)
- projects.blender.org/blender/blender (opens in a new tab)
- vulncheck.com/advisories/blender-before-4.5.15-and-5-x-before-5.2.3-heap-buffer-overflow-via-point-cache (opens in a new tab)