Blender before 4.5.15 and 5.x before 5.2.3 contains a heap buffer overflow vulnerability in the blend file thumbnail
Affects blenderSource GCVE Database
Not known to be exploited · CVSS 8.5 High · fixed in 4.5.15 : patch blender soon.
Data as of 5 Nov 2026, 13:02 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 8.5 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 7.8 |
- Patch
- Available – fixed in 4.5.15
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 30 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Ubuntu 26.10blenderpkg:deb/ubuntu/blender?arch=source&distro=stonkingOther threats | Affected
| Fixed in– |
Ubuntu 26.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=resoluteOther threats | Affected
| Fixed in– |
Ubuntu 24.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=nobleOther threats | Affected
| Fixed in– |
Ubuntu 22.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=jammyOther threats | Affected
| Fixed in– |
Ubuntu 20.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=focalOther threats | Affected
| Fixed in– |
Ubuntu 18.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=bionicOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fix is available in Blender versions 4.5.15 and 5.2.3 and later. Users should upgrade to these or newer versions to remediate the vulnerability. No additional mitigation steps are indicated in the provided data.
Description
A heap buffer overflow vulnerability exists in Blender versions before 4.5.15 and 5.x before 5.2.3. The flaw is due to a 32-bit integer overflow in the blend file thumbnail extractor's thumb_data_vertical_flip() function. Maliciously crafted .blend files with specially designed TEST block dimensions can trigger out-of-bounds writes when previewed by blender-thumbnailer or the Windows shell extension, potentially causing crashes or arbitrary code execution.
References
- ubuntu.com/security/CVE-2026-119719 (opens in a new tab)
- cve.org/CVERecord?id=CVE-2026-119719 (opens in a new tab)
- projects.blender.org/blender/blender/pulls/164279 (opens in a new tab)
- projects.blender.org/blender/blender/commit/d723c68112d216099c9b24dab5c8440bab7add08 (opens in a new tab)
- projects.blender.org/blender/blender/commit/71c10a0217d5e331b215b76773ad23b64974bd97 (opens in a new tab)
- projects.blender.org/blender/blender (opens in a new tab)
- vulncheck.com/advisories/blender-before-4.5.15-and-5-x-before-5.2.3-heap-buffer-overflow-via-thumbnail-extraction (opens in a new tab)