Skip to main content
CVE-2026-119722VulnerabilityPublished Updated

Blender before 4.5.15 and 5.x before 5.2.3 contains a heap out-of-bounds access vulnerability in read_struct() that

Affects blenderSource GCVE Database

0
Compare
Authoritative record:CVE-2026-119722· High 8.5

Not known to be exploited · CVSS 8.5 High · fixed in 4.5.15 : patch blender soon.

Data as of 5 Nov 2026, 13:02 UTC

CVSS 4.0 base score
8.5High
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.08.5
CNA (VulnCheck)CVSS 3.17.8
CNACVSS 4.08.5
Patch
Available – fixed in 4.5.15
CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 30 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 26.10blenderpkg:deb/ubuntu/blender?arch=source&distro=stonkingOther threatsAffected
  • 5.0.1+dfsg-1ubuntu1 – 5.0.1+dfsg-5
4 affected builds
Fixed in–
Ubuntu 26.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=resoluteOther threatsAffected
  • =4.3.2+dfsg-2ubuntu2
  • =5.0.1+dfsg-1ubuntu1
Fixed in–
Ubuntu 24.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=nobleOther threatsAffected
  • 3.6.2+dfsg-2ubuntu1 – 4.0.2+dfsg-1ubuntu8
8 affected builds
Fixed in–
Ubuntu 22.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=jammyOther threatsAffected
  • 2.93.3+dfsg-3 – 3.0.1+dfsg-7
4 affected builds
Fixed in–
Ubuntu 20.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=focalOther threatsAffected
  • 2.80+dfsg-3 – 2.82+dfsg-1build1
7 affected builds
Fixed in–
Ubuntu 18.04 LTSblenderpkg:deb/ubuntu/blender?arch=source&distro=bionicOther threatsAffected
  • 2.78.c+dfsg0-2build1 – 2.79+dfsg0-3build1
6 affected builds
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in Blender versions 4.5.15 and 5.2.3 and later. Users and administrators should upgrade to these versions or newer to remediate this vulnerability. No other mitigation or workaround is indicated in the provided data.

Description

Blender versions before 4.5.15 and 5.x before 5.2.3 contain a heap out-of-bounds access vulnerability in the read_struct() function. This flaw occurs because size validation is skipped when a .blend file's SDNA struct layout compares equal. An attacker can craft a malicious .blend file with short blocks that cause heap memory overruns during field reads, writes, and pointer dereferences, potentially leading to crashes or arbitrary code execution.

References

Community reviews

Loading reviews…