Skip to main content
CVE-2026-77635VulnerabilityPublished Updated

Cakephp: Prior to versions 5.1.10, 5.2.15, and 5.3.7 on their respective release lines, FunctionsBuilder::jsonValue()

Affects cakephpSource GCVE Database

0
Compare

Not known to be exploited · CVSS 9.2 Critical · fixed in 5.1.10 : patch cakephp as a priority.

Data as of 3 Nov 2026, 23:36 UTC

CVSS 4.0 base score
9.2Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 5.1.10
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:L/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTScakephppkg:deb/ubuntu/cakephp?arch=source&distro=jammyOther threatsAffected
  • =2.10.11-2.1
  • =2.10.24-1
Fixed in–
Ubuntu 20.04 LTScakephppkg:deb/ubuntu/cakephp?arch=source&distro=focalOther threatsAffected
  • =2.10.11-2
Fixed in–
Ubuntu Pro 16.04 LTScakephppkg:deb/ubuntu/cakephp?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • =2.7.2-1
  • =2.8.0-1
  • =2.8.0-1ubuntu0.1~esm1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade CakePHP to versions 5.1.10, 5.2.15, or 5.3.7 on the respective release lines to apply the official fix for this SQL injection vulnerability. No other mitigation is indicated by the vendor advisory.

Description

CakePHP versions prior to 5.1.10, 5.2.15, and 5.3.7 on their respective release lines contain a SQL injection vulnerability in the FunctionsBuilder::jsonValue() method when used with the PostgresDriver. This occurs if user-controlled data is passed to the jsonPath parameter. The vulnerability has a high severity with a CVSS score of 9.2 and is fixed in the specified versions.

References

Community reviews

Loading reviews…