Skip to main content
CVE-2026-77337VulnerabilityPublished Updated

Cakephp: Versions before 2.11.2, from 3.0.0 through 3.3.6, and from 4.0.0 through 4.2.0 allow authentication bypass

Affects cakephpSource GCVE Database

0
Compare
Authoritative record:CVE-2026-77337· Critical 9.1

Not known to be exploited · CVSS 9.1 Critical · fixed in 2.11.2 : patch cakephp as a priority.

Data as of 3 Nov 2026, 23:36 UTC

CVSS 4.0 base score
9.1Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.11.2
CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 24 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 3 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
Ubuntu 22.04 LTScakephppkg:deb/ubuntu/cakephp?arch=source&distro=jammyOther threatsAffected
  • =2.10.11-2.1
  • =2.10.24-1
Fixed in–
Ubuntu 20.04 LTScakephppkg:deb/ubuntu/cakephp?arch=source&distro=focalOther threatsAffected
  • =2.10.11-2
Fixed in–
Ubuntu Pro 16.04 LTScakephppkg:deb/ubuntu/cakephp?arch=source&distro=esm-apps-legacy/xenialOther threatsAffected
  • =2.7.2-1
  • =2.8.0-1
  • =2.8.0-1ubuntu0.1~esm1
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected CakePHP Authentication plugin versions to 2.11.2, 3.3.7, or 4.2.1 or later where the vulnerability is fixed. No other mitigation is indicated by the vendor advisory.

Description

CakePHP Authentication plugin versions before 2.11.2, from 3.0.0 through 3.3.6, and from 4.0.0 through 4.2.0 contain a vulnerability that allows authentication bypass and potential CPU or memory exhaustion when using the CookieAuthenticator with unencrypted, forgeable legacy tokens. This flaw is addressed in versions 2.11.2, 3.3.7, and 4.2.1.

References

Community reviews

Loading reviews…