Skip to main content
VulnerabilityPublished Updated

CVE-2024-3955: Cbpi4 · CraftBeerPi 4 allows arbitrary code execution

Affects cbpi4Source GCVE Database

0

Not known to be exploited · CVSS 9.8 Critical : upgrade to 4.4.1.a1 as a priority.

Data as of 27 Oct 2026, 17:42 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 4.4.1.a1
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 2 May 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade cbpi4 to 4.4.1.a1.

Affected software

ProductAffectedFixed in
PyPIcbpi4Affected
  • >=4.0.0.58 <4.4.1.a1
Fixed in
  • 4.4.1.a1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade affected CraftBeerPi 4 installations to version 4.4.1.a1 or later, where this vulnerability is fixed. No other mitigation or temporary workaround is indicated.

Description

CraftBeerPi 4 versions from 4.0.0.58 up to but not including 4.4.1.a1 contain a critical vulnerability (CVE-2024-3955) that allows arbitrary code execution. The flaw arises because the "logtime" URL GET parameter is passed without validation to the os.system function, enabling remote attackers to execute arbitrary commands. This vulnerability has a CVSS score of 9.8, indicating a critical severity level. A fix is available in version 4.4.1.a1.

References

Community reviews

Loading reviews…