Skip to main content
CVE-2025-65719VulnerabilityPublished Updated

Open Source Kubectl MCP Server vulnerable to arbitrary code execution via user interaction with crafted HTML page

Affects kubectl-mcp-serverSource GCVE Database

0
Authoritative record:CVE-2025-65719· Critical 9.8

Not known to be exploited · CVSS 9.8 Critical : upgrade to 1.2.0 as a priority.

Data as of 27 Oct 2026, 18:28 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.2.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 May 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade kubectl-mcp-server to 1.2.0.

Affected software

ProductAffectedFixed in
npmkubectl-mcp-serverAffected
  • <1.2.0
Fixed in
  • 1.2.0
PyPIkubectl-mcp-serverAffected
  • <1.2.0
Fixed in
  • 1.2.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Open Source Kubectl MCP Server to version 1.2.0 or later, where this vulnerability is fixed. No other mitigation steps are indicated or required according to the available data.

Description

Open Source Kubectl MCP Server version 1.1.1 and earlier contains a critical vulnerability that allows attackers to execute arbitrary code on a victim system. This occurs through user interaction with a crafted HTML page. The vulnerability is identified as CWE-94 and has a CVSS score of 9.8, indicating a high severity with network attack vector, no privileges required, and no user interaction needed beyond viewing the malicious page. A fix is available in version 1.2.0.

References

Community reviews

Loading reviews…