Skip to main content
VulnerabilityPublished Updated

CVE-2025-3248: Langflow Unauth RCE

Affects langflowSource GCVE Database

0
Authoritative record:CVE-2025-3248· Critical 9.8

Exploited in the wild · KEV due 26 May 2025 · public exploit available (Metasploit, Exploit-DB) : upgrade to 1.3.0 now.

Data as of 27 Oct 2026, 18:29 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
KEV deadline
 US federal agencies must patch by this date; a sensible deadline for everyone else. Other KEV due dates
Patch
Available – fixed in 1.3.0, 0.3.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

t = 0 is the CVE’s publication on cve.org

  1. Disclosed: evidence found.

    CVE published 7 Apr 2025

  2. Exploited in the wild: evidence found.

    Listed in CISA KEV 28 days after disclosure

  3. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

Timeline

  1. CVE published

    on cve.org

    , t = 0

  2. First Exploit-DB entry (opens in a new tab)

    Langflow 1.3.0 - Remote Code Execution (RCE) +1 more

    , 11 days after disclosure

  3. Added to CISA KEV (opens in a new tab)

    exploitation confirmed · ransomware use known

    , 28 days after disclosure

  4. In Threat Radar

    record ingested

    , 29 days after disclosure

  5. KEV remediation due

    US federal deadline

    , 49 days after disclosure

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CISA KEV (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade langflow to 1.3.0; langflow-base to 0.3.0.

Affected software

ProductAffectedFixed in
PyPIlangflowAffected
  • <1.3.0
Fixed in
  • 1.3.0
PyPIlangflow-baseAffected
  • <0.3.0
Fixed in
  • 0.3.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Apply the official patches by upgrading Langflow to version 1.3.0 or later (or 0.3.0 or later for the older branch). Since a patch is available and fixed versions are published, remediation should be prioritized. Use available detection templates (e.g., Nuclei) to identify vulnerable instances. No additional vendor advisory states that no action is required or that the issue is mitigated by other means.

Description

Langflow versions prior to 1.3.0 contain a critical remote code execution vulnerability in the /api/v1/validate/code endpoint. This flaw allows unauthenticated attackers to send crafted HTTP requests that execute arbitrary code on the affected system. The vulnerability is identified as CVE-2025-3248 and has a CVSS 4.0 base score of 9.3, indicating a critical severity. Fixed versions 1.3.0 and 0.3.0 are available. Public exploit code exists, including Metasploit and Exploit-DB modules, and detection templates are available via Nuclei. No known exploitation in the wild has been reported.

References

Community reviews

Loading reviews…