Skip to main content
VulnerabilityPublished Updated

pycares · Cross-site Scripting

Affects checkovSource GCVE Database

0

Mentioned vulnerabilities

CVSS 5.6 Medium : upgrade to 2.1.0 when convenient.

Data as of 18 Sep 2026, 01:37 UTC

CVSS 3.1 base score
5.6Medium
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 2.1.0
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:L

What to do

Upgrade checkov to 2.1.0.

Affected software

ProductAffectedFixed in
Homebrewcheckovpkg:brew/checkovOther threatsAffected
  • >=2.0.615 <2.1.0
Fixed in
  • 2.1.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Users should update pycares to version 4.2.0 or later to remediate this vulnerability. This is the official fix provided by the vendor.

Description

pycares versions prior to 4.2.0 contain a cross-site scripting (XSS) vulnerability identified as CVE-2021-3672. This vulnerability involves improper neutralization of input during web page generation, which can lead to limited confidentiality, integrity, and availability impacts. The issue is addressed by updating to pycares version 4.2.0 or later.

References

Community reviews

Loading reviews…