Skip to main content
VulnerabilityPublished Updated

CVE-2026-49476: Checkov · Soup Sieve has Memory Exhaustion via Large Comma-Separated Selector Lists

Affects checkovSource GCVE Database

0
Compare

Not known to be exploited · CVSS 7.5 High : upgrade to 3.2.530 soon.

Data as of 30 Oct 2026, 20:25 UTC

CVSS 3.1 base score
7.5High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 3.2.530
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 13 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.

What to do

Upgrade checkov to 3.2.530.

Affected software

ProductAffectedFixed in
Homebrewcheckovpkg:brew/checkovOther threatsAffected
  • >=1.0.855 <3.2.530
Fixed in
  • 3.2.530

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fixed version of soupsieve is available in 3.2.530. Users should upgrade to version 3.2.530 or later to remediate this vulnerability. No additional mitigation actions are required if the upgrade is applied.

Description

A memory exhaustion vulnerability exists in soupsieve's CSS selector parser used by Beautiful Soup 4. The parser allocates unbounded memory when compiling large comma-separated selector lists, allowing an attacker to cause denial of service by supplying a crafted CSS selector string. This can lead to out-of-memory conditions or process termination in Python applications using soupsieve. The vulnerability affects soupsieve versions from 1.0.855 up to but not including 3.2.530 and is fixed in version 3.2.530.

References

Community reviews

Loading reviews…