CVE-2026-104874: Reference leak in CIMultiDict/MultiDict items-view union and subtraction
Affects checkovSource GCVE Database
Not known to be exploited · CVSS 5.3 Medium : upgrade to 3.3.20 when convenient.
Data as of 30 Oct 2026, 20:25 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 38% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 3.3.20
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:LExploitation evidence
Disclosed: evidence found.
CVE published 2 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 30 Oct 2026.
What to do
Upgrade checkov to 3.3.20.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Homebrewcheckovpkg:brew/checkovOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A patch is available and should be applied. The issue is fixed in version 3.3.20 of the affected product. Users should upgrade to this version or later to remediate the memory leak. No other mitigation or workaround is indicated.
Description
A reference leak vulnerability exists in the items-view union and subtraction operators of aio-libs/multidict versions 6.7.0 through 6.9.0. This flaw allows a remote client to cause unbounded memory growth by leaking key-identity and value objects during certain set operations on dictionary views. The leak occurs because new references are created but not properly released in specific code paths. This issue can cause server processes using these versions to consume increasing amounts of memory until termination.
References
- github.com/aio-libs/multidict/security/advisories/GHSA-54p9-h82j-f925 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-104874 (opens in a new tab)
- github.com/aio-libs/multidict/commit/350b4a07bf8ff851b6d7544e81b1c748bdc74c40 (opens in a new tab)
- github.com/aio-libs/multidict (opens in a new tab)
- github.com/aio-libs/multidict/releases/tag/v6.9.1 (opens in a new tab)