Coder 2.28.0 before 2.29.22, 2.30.0 before 2.34.13, 2.35.0 before 2.35.10, 2.36.0 before 2.36.8, 2.37.0 before 2.37.5
Source GCVE Database
Not known to be exploited · CVSS 2.3 Low : upgrade to 2.37.5 when convenient.
Data as of 4 Nov 2026, 19:45 UTC
Thin evidence
One scorer or none| CNA (VulnCheck) | CVSS 4.0 | 2.3 |
|---|---|---|
| CNA (VulnCheck) | CVSS 3.1 | 4.9 |
- Patch
- Available – fixed in 2.37.5, 2.36.8, 2.35.10 +3
CVSS:4.0/AV:N/AC:H/AT:P/PR:L/UI:N/VC:L/VI:L/VA:N/SC:L/SI:L/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Nov 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.
What to do
Upgrade to a fixed release listed under Affected software.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
| codercoder | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Fixed versions are indicated by the version ranges in the description (e.g., 2.29.22, 2.34.13, 2.35.10, 2.36.8, 2.37.5, 2.38.1). Users should upgrade to these or later versions to remediate the vulnerability. No vendor advisory or patch links were provided, so confirm patch availability and upgrade guidance from official vendor sources.
Description
Coder versions 2.28.0 before 2.29.22, 2.30.0 before 2.34.13, 2.35.0 before 2.35.10, 2.36.0 before 2.36.8, 2.37.0 before 2.37.5, and 2.38.0 before 2.38.1 contain a path traversal vulnerability in the AI Gateway passthrough router. This vulnerability allows authenticated users to send percent-encoded dot segments in paths to access unintended provider endpoints using the deployment's centrally managed provider key.
References
- github.com/coder/coder/security/advisories/GHSA-373r-678h-hjc6 (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2026-121967 (opens in a new tab)
- github.com/coder/coder/pull/30178 (opens in a new tab)
- vulncheck.com/advisories/coder-before-2.29.22-2.34.13-2.35.10-2.36.8-2.37.5-and-2.38.1-ai-gateway-path-traversal (opens in a new tab)