Skip to main content
VulnerabilityPublished

CVE-2026-116591: compress zstd · Panic on two-block frames

Affects github.com/klauspost/compress/zstdSource GCVE Database

0
Authoritative record:CVE-2026-116591· High 8.7

Not known to be exploited · CVSS 8.7 High : upgrade to 1.20.2 soon.

Data as of 27 Oct 2026, 16:28 UTC

CVSS 4.0 base score
8.7High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 1.20.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 26 Oct 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade github.com/klauspost/compress/zstd to 1.20.2.

Affected software

ProductAffectedFixed in
Gogithub.com/klauspost/compress/zstdAffected
  • <1.20.2
Fixed in
  • 1.20.2

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in version 1.20.2 of github.com/klauspost/compress/zstd. Users should upgrade to this version or later to prevent crashes from crafted zstd frames. No other mitigation is required as the vulnerability is addressed by the official patch.

Description

A vulnerability in github.com/klauspost/compress/zstd versions prior to 1.20.2 causes a panic due to an out-of-range slice index when decompressing crafted two-block zstd frames. The flaw arises from improper handling of Huffman-weight tables in the FSE decoder, leading to reuse of stale state and an invalid decode table. This can crash any program decompressing untrusted zstd input. The issue is fixed in version 1.20.2.

References

Community reviews

Loading reviews…