CVE-2026-110678: Cpanel::JSON::XS versions before 4.80 for Perl allow memory exhaustion by buffering incremental
Source GCVE Database
Not known to be exploited · CVSS 7.5 High : upgrade to 4.80 soon.
Data as of 29 Oct 2026, 20:15 UTC
Thin evidence
One scorer or none| CISA-ADP | CVSS 3.1 | 7.5 |
|---|
- EPSS
- 0.1% chance of exploitation in 30 days – higher than 6% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.80
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 19 Oct 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade Cpanel-JSON-XS (Perl module) to 4.80.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Cpanel-JSON-XS | Affected
| Fixed in
|
CPANCpanel-JSON-XSpkg:cpan/Cpanel-JSON-XSOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
A fixed version 4.80 or later should be applied to remediate this vulnerability. Until patched, avoid processing untrusted incremental JSON input streams with vulnerable versions.
Description
Cpanel::JSON::XS versions before 4.80 for Perl contain a vulnerability that allows memory exhaustion via incremental input buffering in the incr_parse function. The parser incorrectly manages buffer size checks, enabling an attacker streaming data to cause unbounded memory growth and potentially exhaust process memory.