Skip to main content
VulnerabilityPublished

CVE-2026-73099: Apache Juneau · Cross-Site Request Forgery (CSRF) Vulnerability

Source GCVE Database

0
Compare
Authoritative record:CVE-2026-73099· Critical 10.0

Not known to be exploited · CVSS 10.0 Critical : upgrade to 9.2.1 as a priority.

Data as of 5 Nov 2026, 13:17 UTC

CVSS 4.0 base score
10.0Critical
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (apache)CVSS 4.010.0
Patch
Available – fixed in 9.2.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade Apache Juneau and org.apache.juneau/juneau-rest-server. to 9.2.1.

Affected software

ProductAffectedFixed in
Apache Juneauorg.apache.juneau:juneau-rest-server.Affected
  • <9.2.1
Fixed in
  • 9.2.1
Mavenorg.apache.juneau/juneau-rest-server.pkg:maven/org.apache.juneau/juneau-rest-server.Other threatsAffected
  • <9.2.1
Fixed in
  • 9.2.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Apache Juneau to version 9.2.1 or later, where the vulnerability is fixed. If upgrading is not immediately possible, applications that do not use the 'content' query parameter should set 'disableContentParam' to true to disable this feature and mitigate the risk.

Description

Apache Juneau versions through 9.2.0 have a Cross-Site Request Forgery (CSRF) vulnerability. The REST server accepts a 'content' query parameter that replaces the request body and is enabled by default on all HTTP methods, including GET. This allows an attacker to craft a cross-site link that delivers an attacker-chosen request body without triggering CORS preflight checks, bypassing protections that rely on HTTP method or content type instead of anti-CSRF tokens. The issue is fixed in version 9.2.1. Users can also mitigate by disabling the content parameter if it is not used.

References

Community reviews

Loading reviews…