Skip to main content
VulnerabilityPublished

CVE-2026-122151: Presenton · Cross-Site Request Forgery

Affects presentonSource GCVE Database

0
Compare
Authoritative record:CVE-2026-122151· Medium 5.3

Public exploit available · CVSS 5.3 Medium · fixed in 0.9.12 : patch presenton as a priority.

Data as of 5 Nov 2026, 04:29 UTC

CVSS 4.0 base score
5.3Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulDB)CVSS 4.05.3
CNA (VulDB)CVSS 3.14.3
CNA (VulDB)CVSS 3.04.3
CNA (VulDB)CVSS 2.05.0
Affects
Presenton up to 0.9.11
Patch
Available – fixed in 0.9.12
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:L/VA:N/SC:N/SI:N/SA:N/E:P

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: evidence found.

    CVSS exploit maturity: proof of concept public

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), CVSS vector, the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Affected software

ProductAffectedFixed in
GitHubpresenton/presentonpkg:github/presenton/presentonOther threatsAffected
  • <=0.9.11-beta
Fixed in–

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Upgrade Presenton to version 0.9.12-beta, which contains the official fix for this CSRF vulnerability. No other mitigation steps are specified or required according to the available data.

Description

A cross-site request forgery (CSRF) vulnerability exists in Presenton versions up to 0.9.11-beta in the JSON.parse function of the /api/user-config endpoint within the User Configuration Handler component. This vulnerability allows remote attackers to manipulate user configuration via CSRF attacks. The issue is addressed by upgrading to version 0.9.12-beta.

References

Community reviews

Loading reviews…