Skip to main content
VulnerabilityPublished Updated

CVE-2026-61687: github.com/hatchet-dev/hatchet · Hatchet - Unauthenticated OAuth state CSRF / login-CSRF via empty-state collision in ValidateOAuthState

Affects github.com/hatchet-dev/hatchetSource GCVE Database

0
Compare
Authoritative record:CVE-2026-61687· High 7.1

Not known to be exploited · CVSS 7.1 High : upgrade to 0.91.1 soon.

Data as of 5 Nov 2026, 00:41 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
Patch
Available – fixed in 0.91.1
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 21 Sep 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 5 Nov 2026.

What to do

Upgrade github.com/hatchet-dev/hatchet to 0.91.1.

Affected software

ProductAffectedFixed in
Gogithub.com/hatchet-dev/hatchetAffected
  • <0.91.1
Fixed in
  • 0.91.1

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A patch is available and the issue is fixed in Hatchet version 0.91.1. Users should upgrade to version 0.91.1 or later to remediate this vulnerability. No additional mitigations are indicated by the vendor advisory.

Description

Hatchet versions up to v0.86.26 are vulnerable to an OAuth state Cross-Site Request Forgery (CSRF) vulnerability. The flaw arises because the session key for OAuth state is cleared to an empty string instead of being removed after a successful OAuth callback. This allows an attacker to reuse an empty state parameter to bind a victim's authenticated session to an attacker-controlled OAuth identity, enabling login CSRF or account takeover. The vulnerability affects deployments with enabled Google, GitHub, or Slack OAuth integrations where the victim has completed at least one OAuth flow in the current session. The issue is fixed in version 0.91.1.

References

Community reviews

Loading reviews…