Skip to main content
CVE-2025-71454VulnerabilityPublished

vtenext before 25.02.2 contains a cross-site request forgery protection bypass because csrf_check() in

Source GCVE Database

0
Compare
Authoritative record:CVE-2025-71454· Medium 6.9

Not known to be exploited · CVSS 6.9 Medium : upgrade to 25.02.2 when convenient.

Data as of 4 Nov 2026, 22:53 UTC

CVSS 4.0 base score
6.9Medium
How severe the flaw is on the 0–10 CVSS scale.

Thin evidence

One scorer or none
CVSS scores by source
CNA (VulnCheck)CVSS 4.06.9
CNA (VulnCheck)CVSS 3.16.5
Patch
Available – fixed in 25.02.2
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:A/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 4 Nov 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponized: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 4 Nov 2026.

What to do

Upgrade vtenext to 25.02.2.

Affected software

ProductAffectedFixed in
vtenextvtenextAffected
  • <25.02.2
Fixed in
  • 25.02.2

AI-suggested

A fix is available in vtenext version 25.02.2 and later. Users should upgrade to version 25.02.2 or newer to remediate this vulnerability. Until then, avoid relying on non-POST requests for state-changing operations or implement additional CSRF protections that validate tokens for all request methods.

Description

vtenext versions before 25.02.2 have a vulnerability where the CSRF protection mechanism can be bypassed. The function csrf_check() in include/utils/VteCsrf.php does not validate the __csrf_token for non-POST requests, allowing attackers to trick logged-in users into executing state-changing GET requests. This can lead to unauthorized actions performed with the user's privileges.

References

Community reviews

Loading reviews…