Skip to main content
VulnerabilityPublished Updated

CVE-2026-67324: Cruft · GitPython unsafe clone option gate bypass through joined short options

Affects cruftSource GCVE Database

0
Authoritative record:CVE-2026-67324· Critical 9.3

Not known to be exploited · CVSS 9.3 Critical : upgrade to 2.16.0_11 as a priority.

Data as of 26 Oct 2026, 17:42 UTC

CVSS 4.0 base score
9.3Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.16.0_11
CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 1 Aug 2026

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade cruft to 2.16.0_11.

Affected software

ProductAffectedFixed in
Homebrewcruftpkg:brew/cruftOther threatsAffected
  • >=2.16.0_9 <2.16.0_11
Fixed in
  • 2.16.0_11

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

A fix is available in GitPython version 2.16.0_11 that properly parses joined short options such as '-u<value>' and canonicalizes them to their base short option before checking against the unsafe option set. Users should upgrade to this fixed version to prevent bypass of the unsafe option gate. Until upgrading, avoid passing untrusted input to the multi_options parameter or explicitly set allow_unsafe_options to true only when safe. The vendor advisory recommends maintaining command-specific metadata to recognize all forms of unsafe options including joined short options.

Description

GitPython version 3.1.50 contains a vulnerability where the default unsafe option gate intended to block dangerous git clone options does not recognize joined short-option forms such as '-u<helper>'. This allows an attacker controlling clone options to bypass the safety check and execute local commands via Git's upload-pack option. The issue arises because the option canonicalization treats '-u<value>' as a distinct option rather than the unsafe '-u' short option. A fix is available in version 2.16.0_11.

References

Community reviews

Loading reviews…