CVE-2017-20188: Zimbra zm-ajax · Cross-site Scripting
Affects Zimbra zm-ajaxSource CVE Database V5
Not known to be exploited · CVSS 2.6 Low.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 2 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubzimbra/zm-ajaxpkg:github/zimbra/zm-ajaxOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediate upgrade of Zimbra Collaboration Suite to version 8.8.2 or later, which contains the official patch addressing CVE-2017-20188.
- Implement strict Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts and reduce the impact of potential XSS attacks.
- Conduct thorough input validation and output encoding on all user-supplied data within custom Zimbra extensions or integrations to prevent injection of malicious content.
- Employ web application firewalls (WAFs) with rules tailored to detect and block XSS payloads targeting Zimbra interfaces.
- Educate users about the risks of interacting with suspicious links or messages that could trigger XSS exploitation, emphasizing cautious behavior in email and collaboration platforms.
- Regularly audit and monitor Zimbra logs for unusual activities or error messages related to XFormItem.setError function calls that might indicate attempted exploitation.
- For organizations unable to upgrade immediately, consider isolating the affected Zimbra services behind additional security layers or restricting access to trusted networks to reduce exposure.
Description
A vulnerability has been found in Zimbra zm-ajax up to 8.8.1 and classified as problematic. Affected by this vulnerability is the function XFormItem.prototype.setError of the file WebRoot/js/ajax/dwt/xforms/XFormItem.js. The manipulation of the argument message leads to cross site scripting. The attack can be launched remotely. The complexity of an attack is rather high. The exploitation appears to be difficult. Upgrading to version 8.8.2 is able to address this issue. The identifier of the patch is 8d039d6efe80780adc40c6f670c06d21de272105. It is recommended to upgrade the affected component. The identifier VDB-249421 was assigned to this vulnerability.