CVE-2020-36846: TIMLEGGE IO::Compress::Brotli · Dependency on Vulnerable Third-Party Component
Affects TIMLEGGE IO::Compress::BrotliSource CVE Database V5
Mentioned vulnerabilities
Not known to be exploited · CVSS 9.8 Critical.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 50% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 30 May 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| TIMLEGGE IO::Compress::Brotli | Affected
| Fixed in– |
AI-suggested
1. Immediate upgrade of the IO::Compress::Brotli Perl module to version 0.007 or later, ensuring the embedded Brotli library is updated to version 1.0.8 or above. 2. If upgrading is not immediately possible, refactor applications to avoid using the "one-shot" decompression API; instead, implement the "streaming" API with enforced chunk size limits to prevent processing excessively large data chunks. 3. Conduct a thorough inventory of all software components and dependencies to identify indirect usage of the vulnerable module, including third-party applications and libraries. 4. Implement network-level protections such as web application firewalls (WAFs) to detect and block anomalous decompression requests with unusually large input lengths. 5. Monitor application logs and system behavior for signs of crashes or abnormal decompression activity that could indicate attempted exploitation. 6. Engage in secure software development lifecycle (SDLC) practices to regularly update and audit third-party dependencies, reducing future supply chain risks. 7. Educate development and operations teams about the risks of using outdated compression libraries and the importance of timely patching.
Description
A buffer overflow, as described in CVE-2020-8927, exists in the embedded Brotli library. Versions of IO::Compress::Brotli prior to 0.007 included a version of the brotli library prior to version 1.0.8, where an attacker controlling the input length of a "one-shot" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your IO::Compress::Brotli module to 0.007 or later. If one cannot update, we recommend to use the "streaming" API as opposed to the "one-shot" API, and impose chunk size limits.
References
- github.com/google/brotli/pull/826 (opens in a new tab)
- github.com/advisories/GHSA-5v8v-66v8-mwm7 (opens in a new tab)
- github.com/timlegge/perl-IO-Compress-Brotli/blob/8b44c83b23bb4658179e1494af4b725a1bc476bc/Changes (opens in a new tab)
- nvd.nist.gov/vuln/detail/CVE-2020-8927 (opens in a new tab)
- github.com/google/brotli/commit/223d80cfbec8fd346e32906c732c8ede21f0cea6 (opens in a new tab)