CVE-2022-4876: Kaltura mwEmbed · Cross Site Scripting
Affects Kaltura mwEmbedSource CVE Database V5
Not known to be exploited · CVSS 3.5 Low.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 44% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 4 Jan 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
AI-suggested
European organizations should prioritize upgrading Kaltura mwEmbed to version 2.96.rc2 or later to apply the official patch. If immediate upgrade is not feasible, implementing web application firewall (WAF) rules to sanitize or block suspicious HTTP_X_FORWARDED_HOST header values can reduce exposure. Additionally, organizations should conduct security awareness training to educate users about the risks of clicking unknown or suspicious links. Regular security assessments and penetration testing focusing on input validation and header manipulation can help identify similar vulnerabilities. Monitoring web server logs for unusual HTTP_X_FORWARDED_HOST header values may provide early detection of attempted exploitation. Finally, applying Content Security Policy (CSP) headers can mitigate the impact of XSS by restricting the execution of unauthorized scripts in browsers.
Description
A vulnerability was found in Kaltura mwEmbed up to 2.96.rc1 and classified as problematic. This issue affects some unknown processing of the file includes/DefaultSettings.php. The manipulation of the argument HTTP_X_FORWARDED_HOST leads to cross site scripting. The attack may be initiated remotely. Upgrading to version 2.96.rc2 is able to address this issue. The patch is named 13b8812ebc8c9fa034eed91ab35ba8423a528c0b. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-217427.