CVE-2022-4957: librespeed speedtest · Cross-site Scripting
Affects librespeed speedtestSource CVE Database V5
Not known to be exploited · CVSS 3.5 Low.
Data as of 26 Oct 2026, 17:16 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 46% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 3 Dec 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHublibrespeed/speedtestpkg:github/librespeed/speedtestOther threats | Affected
| Fixed in– |
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediate upgrade to librespeed speedtest version 5.2.5 or later, which contains the patch addressing this vulnerability.
- Implement strict input validation and output encoding on all user-supplied inputs, especially parameters like 'id' in results/stats.php, to prevent script injection.
- Employ Content Security Policy (CSP) headers to restrict the execution of unauthorized scripts in browsers accessing the speedtest application.
- Conduct user awareness training to reduce the likelihood of users clicking on suspicious links that could exploit this vulnerability.
- Monitor web application logs for unusual parameter values or repeated attempts to inject scripts via the 'id' parameter.
- If upgrading immediately is not feasible, consider restricting access to the speedtest application to trusted internal networks or authenticated users only, reducing exposure.
- Regularly review and update web application security configurations and perform periodic vulnerability assessments to detect similar issues proactively.
Description
A vulnerability was found in librespeed speedtest up to 5.2.4. It has been declared as problematic. Affected by this vulnerability is an unknown functionality of the file results/stats.php. The manipulation of the argument id leads to cross site scripting. The attack can be launched remotely. Upgrading to version 5.2.5 is able to address this issue. The patch is named a85f2c086f3449dffa8fe2edb5e2ef3ee72dc0e9. It is recommended to upgrade the affected component. The associated identifier of this vulnerability is VDB-246643.