Skip to main content
VulnerabilityPublished Updated

CVE-2023-34042: Incorrect Permission Assignment for spring-security.xsd

Affects Spring SecuritySource CVE Database V5

0

Not known to be exploited · CVSS 4.1 Medium · fixed in 6.1.4 : update Spring Security when convenient.

Data as of 26 Oct 2026, 10:12 UTC

CVSS 3.1 base score
4.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.2% chance of exploitation in 30 days – higher than 14% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 6.1.4, 6.0.7, 5.8.7 +1
CVSS:3.1/AV:L/AC:H/PR:H/UI:N/S:U/C:N/I:H/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 5 Feb 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade org.springframework.security/spring-security-config to 6.1.4, 6.0.7, 5.8.7 or 5.7.11.

Affected software

ProductAffectedFixed in
Mavenorg.springframework.security/spring-security-configpkg:maven/org.springframework.security/spring-security-configOther threatsAffected
  • <5.7.11
  • <5.8.7
  • <6.0.7
  • <6.1.4
Fixed in
  • 5.7.11
  • 5.8.7
  • 6.0.7
  • 6.1.4

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

To mitigate this vulnerability, European organizations should: 1) Immediately upgrade Spring Security to the latest patched versions (6.1.4 or later, 6.0.7 or later, 5.8.7 or later, or 5.7.11 or later) where the permission issue is resolved. 2) Audit file system permissions on all Spring Security-related files, especially spring-security.xsd, ensuring they are not world-writable and adhere to the principle of least privilege. 3) Implement strict access controls and monitoring on servers running Spring Security to detect unauthorized file modifications, using file integrity monitoring tools. 4) Restrict local access to application servers to trusted administrators only, minimizing the risk of local privilege abuse. 5) Incorporate this vulnerability into vulnerability management and patching workflows to ensure timely updates. 6) Conduct security reviews of application deployment environments to verify no other critical resources have insecure permissions. 7) Educate development and operations teams about the risks of improper file permissions and secure configuration management practices. These steps go beyond generic advice by focusing on permission audits, access restrictions, and proactive monitoring tailored to the nature of this vulnerability.

Description

The spring-security.xsd file inside the spring-security-config jar is world writable which means that if it were extracted it could be written by anyone with access to the file system. While there are no known exploits, this is an example of “CWE-732: Incorrect Permission Assignment for Critical Resource” and could result in an exploit. Users should update to the latest version of Spring Security to mitigate any future exploits found around this issue.

References

Community reviews

Loading reviews…