CVE-2023-39804: tar · n/a
Affects tarSource CVE Database V5
Not known to be exploited · CVSS 6.2 Medium : upgrade to 1.35 when convenient.
Data as of 26 Oct 2026, 06:26 UTC
- EPSS
- 0.2% chance of exploitation in 30 days – higher than 20% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.35
CVSS:3.1/AV:L/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 27 Mar 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.
What to do
Upgrade debian/tar to 1.35.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
Debiandebian/tarpkg:deb/debian/tarOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
To mitigate CVE-2023-39804, European organizations should prioritize upgrading GNU tar to version 1.35 or later, where the vulnerability is resolved. Until upgrades are applied, restrict the processing of untrusted or unauthenticated PAX archives, especially from local users or automated systems. Implement file integrity monitoring and logging to detect abnormal crashes or unusual tar activity that may indicate exploitation attempts. Employ access controls to limit local user permissions and reduce the risk of malicious archive injection. In automated pipelines, validate and sanitize archive inputs before processing with GNU tar. Consider using alternative archiving tools with robust security postures if immediate patching is not feasible. Regularly review and update system software inventories to ensure vulnerable versions are identified and remediated promptly. Additionally, educate system administrators about this vulnerability to increase awareness and encourage proactive patch management. For critical systems, implement redundancy and failover mechanisms to minimize downtime caused by potential tar crashes.
Description
In GNU tar before 1.35, mishandled extension attributes in a PAX archive can lead to an application crash in xheader.c.
References
- git.savannah.gnu.org/cgit/tar.git/commit/?id=a339f05cd269013fa133d2f148d73f6f7d4247e4 (opens in a new tab)
- git.savannah.gnu.org/cgit/tar.git/tree/src/xheader.c?h=release_1_34 (opens in a new tab)
- bugs.debian.org/cgi-bin/bugreport.cgi?bug=1058079 (opens in a new tab)
- lists.debian.org/debian-lts-announce/2024/03/msg00008.html (opens in a new tab)