Skip to main content
CVE-2023-41117VulnerabilityPublished Updated

CVE-2023-41117: n/a

Source CVE Database V5

0

Not known to be exploited · CVSS 8.8 High · fixed in 15.4.0 : patch affected systems soon.

Data as of 26 Oct 2026, 07:57 UTC

CVSS 3.1 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 54% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 15.4.0, 14.9.0, 13.12.16 +2
CVSS:3.1/AC:L/AV:N/A:H/C:H/I:H/PR:L/S:U/UI:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 12 Dec 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Affected software

ProductAffectedFixed in
n/a n/aAffected
  • <11.21.32
  • <12.16.20
  • <13.12.16
  • <14.9.0
  • <15.4.0
Fixed in
  • 11.21.32
  • 12.16.20
  • 13.12.16
  • 14.9.0
  • 15.4.0

AI-suggested

European organizations should immediately assess their EPAS deployments to identify affected versions. Specific mitigation steps include: 1) Applying the latest EPAS patches or upgrades to versions 11.21.32, 12.16.20, 13.12.16, 14.9.0, or 15.4.0 or later, as these contain fixes for the vulnerability. 2) Reviewing and restricting the use of SECURITY DEFINER functions and packages, ensuring they do not rely on untrusted or modifiable search_path settings. 3) Explicitly setting the search_path within SECURITY DEFINER functions to a fixed, secure schema list, avoiding reliance on user-controllable defaults. 4) Auditing database roles and privileges to minimize the number of users with low-level access that could exploit this vulnerability. 5) Monitoring database logs for unusual schema search_path changes or unexpected function executions. 6) Implementing network segmentation and access controls to limit exposure of database servers to untrusted networks. 7) Conducting penetration testing focused on search_path manipulation to validate mitigations. These steps go beyond generic advice by focusing on secure configuration of PostgreSQL-specific features and privilege management tailored to EPAS environments.

Description

An issue was discovered in EnterpriseDB Postgres Advanced Server (EPAS) before 11.21.32, 12.x before 12.16.20, 13.x before 13.12.16, 14.x before 14.9.0, and 15.x before 15.4.0. It contain packages, standalone packages, and functions that run SECURITY DEFINER but are inadequately secured against search_path attacks.

References

Community reviews

Loading reviews…