CVE-2023-41913: strongswan · Classic Buffer Overflow
Affects strongswanSource CVE Database V5
Not known to be exploited · CVSS 9.8 Critical : upgrade to 5.9.12 as a priority.
Data as of 26 Oct 2026, 13:47 UTC
- EPSS
- 2.3% chance of exploitation in 30 days – higher than 83% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 5.9.12
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 7 Dec 2023
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade strongswan/strongswan to 5.9.12.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubstrongswan/strongswanpkg:github/strongswan/strongswanOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
- Immediately upgrade all strongSwan installations to version 5.9.12 or later, where the vulnerability is patched.
- If immediate patching is not feasible, implement network-level controls to restrict and monitor IKE_SA_INIT messages, such as firewall rules limiting VPN initiation to trusted IP addresses.
- Deploy intrusion detection/prevention systems (IDS/IPS) with signatures or heuristics capable of detecting anomalous or malformed IKE_SA_INIT packets indicative of exploitation attempts.
- Conduct regular VPN traffic analysis to identify unusual patterns or spikes that may signal scanning or attack activity.
- Enforce strict access controls and network segmentation to limit the potential lateral movement if a VPN gateway is compromised.
- Maintain up-to-date asset inventories to quickly identify and remediate vulnerable strongSwan instances.
- Educate security teams about this vulnerability and incorporate it into incident response plans to ensure rapid detection and containment.
- Collaborate with VPN vendors and security communities to stay informed about emerging exploit techniques and mitigation strategies.
Description
strongSwan before 5.9.12 has a buffer overflow and possible unauthenticated remote code execution via a DH public value that exceeds the internal buffer in charon-tkm's DH proxy. The earliest affected version is 5.3.0. An attack can occur via a crafted IKE_SA_INIT message.
References
- github.com/strongswan/strongswan/releases (opens in a new tab)
- strongswan.org/blog/2023/11/20/strongswan-vulnerability-%28cve-2023-41913%29.html (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce%40lists.fedoraproject.org/message/YPJZPYHBCRXUQGGKQE6TYH4J4RIJH6HO/ (opens in a new tab)
- security.netapp.com/advisory/ntap-20250117-0003/ (opens in a new tab)
- lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/YPJZPYHBCRXUQGGKQE6TYH4J4RIJH6HO/ (opens in a new tab)
- lists.debian.org/debian-lts-announce/2023/11/msg00018.html (opens in a new tab)