Skip to main content
CVE-2023-52306VulnerabilityPublished Updated

CVE-2023-52306: PaddlePaddle · Divide By Zero

Affects PaddlePaddleSource CVE Database V5

0

Not known to be exploited · CVSS 4.7 Medium : upgrade to 2.6.0 when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
4.7Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 41% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 2.6.0
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:N/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 3 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade PaddlePaddle to 2.6.0.

Affected software

ProductAffectedFixed in
PyPIpaddlepaddlepkg:pypi/paddlepaddleOther threatsAffected
  • <2.6.0
Fixed in
  • 2.6.0

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should prioritize upgrading PaddlePaddle to version 2.6.0 or later, where this vulnerability is addressed. If you cannot patch yet, organizations should implement input validation and sanitization to prevent inputs that could cause divide-by-zero conditions in the paddle.lerp function. Restricting access to PaddlePaddle services to trusted users and networks can reduce exposure, as exploitation requires user interaction. Monitoring application logs for crashes or abnormal terminations related to paddle.lerp can help detect attempted exploitation. Employing runtime protections such as sandboxing PaddlePaddle processes or using containerization can limit the impact of crashes. Additionally, organizations should review their AI workflows to identify any external inputs feeding into PaddlePaddle and apply strict validation controls. Incident response plans should include procedures for rapid recovery from service disruptions caused by this vulnerability. Finally, maintaining awareness of vendor updates and applying patches promptly once released is critical to long-term mitigation.

Description

FPE in paddle.lerp in PaddlePaddle before 2.6.0. This flaw can cause a runtime crash and a denial of service.

References

Community reviews

Loading reviews…