Skip to main content
CVE-2023-6011VulnerabilityPublished Updated

CVE-2023-6011: DECE Software Geodi · Cross-site Scripting

Affects DECE Software GeodiSource CVE Database V5

0

Not known to be exploited · CVSS 5.4 Medium : upgrade to 8.0.0.27396 when convenient.

Data as of 26 Oct 2026, 06:26 UTC

CVSS 3.1 base score
5.4Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 32% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.0.0.27396
CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 22 Nov 2023

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-26.

What to do

Upgrade DECE Software Geodi to 8.0.0.27396.

Affected software

ProductAffectedFixed in
DECE Software GeodiAffected
  • =0
  • <8.0.0.27396
Fixed in
  • 8.0.0.27396

AI-suggested

To mitigate CVE-2023-6011 effectively, European organizations should first verify if they are running affected versions of DECE Software Geodi prior to 8.0.0.27396 and plan immediate upgrades to the fixed version once available. In the absence of an official patch, organizations should implement web application firewall (WAF) rules to detect and block typical XSS payloads targeting Geodi interfaces. Input validation and output encoding should be enforced at the application layer, ensuring that all user-supplied data is properly sanitized before storage and rendering. Security teams should conduct thorough code reviews and penetration testing focused on input handling in Geodi. Additionally, user awareness training should be enhanced to reduce the risk of social engineering attacks that could trigger this vulnerability. Monitoring and logging of unusual user input or script execution attempts should be enabled to detect exploitation attempts early. Finally, organizations should isolate Geodi deployments in segmented network zones with strict access controls to limit the potential impact of any successful exploitation.

Description

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in DECE Software Geodi allows Stored XSS.This issue affects Geodi: before 8.0.0.27396.

References

Community reviews

Loading reviews…