Skip to main content
CVE-2023-6279VulnerabilityPublished Updated

CVE-2023-6279: Woostify Sites Library (WordPress plugin) · Missing Authorization

Affects Woostify Sites Library (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 7.1 High.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.1 base score
7.1High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.4% chance of exploitation in 30 days – higher than 42% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:L/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 29 Jan 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Affected software

ProductAffectedFixed in
Unknown Woostify Sites LibraryAffected
  • =0
Fixed in–

AI-suggested

1. Immediate upgrade: Organizations should verify if they use the Woostify Sites Library plugin and update it to version 1.4.8 or later once available, as this will likely include the necessary authorization checks to remediate the vulnerability. 2. Access control review: Restrict user roles and permissions on WordPress sites to the minimum necessary, especially limiting subscriber or low-privilege accounts from accessing AJAX endpoints or administrative functions. 3. Web application firewall (WAF): Deploy or update WAF rules to detect and block suspicious AJAX requests attempting to modify blog options, particularly those that set options to 'activated' or other unusual values. 4. Monitoring and logging: Enable detailed logging of AJAX requests and changes to blog options to detect anomalous activity indicative of exploitation attempts. 5. Disable or remove the plugin if not essential: If the Woostify Sites Library plugin is not critical, consider disabling or uninstalling it until a secure version is available. 6. Harden WordPress security: Implement security best practices such as limiting login attempts, enforcing strong authentication, and isolating administrative functions to reduce the risk of authenticated user exploitation. 7. Incident response readiness: Prepare to respond to potential DoS incidents caused by this vulnerability by having backup and recovery procedures in place to restore site availability quickly.

Description

The Woostify Sites Library WordPress plugin before 1.4.8 does not have authorisation in an AJAX action, allowing any authenticated users, such as subscriber to update arbitrary blog options and set them to 'activated' which could lead to DoS when using a specific option name

References

Community reviews

Loading reviews…