CVE-2023-7151: Product Enquiry for WooCommerce (WordPress plugin) · Cross-Site Scripting (XSS)
Affects Product Enquiry for WooCommerce (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 6.1 Medium.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 0.4% chance of exploitation in 30 days – higher than 39% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:NExploitation evidence
Disclosed: evidence found.
CVE published 16 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| Unknown Product Enquiry for WooCommerce | Affected
| Fixed in– |
AI-suggested
European organizations should immediately verify if their WooCommerce installations use the Product Enquiry plugin and confirm the version. Upgrading to version 3.2 or later, where the vulnerability is fixed, is the primary mitigation. If immediate upgrade is not feasible, implementing Web Application Firewall (WAF) rules to detect and block suspicious 'page' parameter inputs containing script tags or typical XSS payloads can reduce risk. Administrators should be trained to recognize phishing attempts involving suspicious URLs. Additionally, enforcing Content Security Policy (CSP) headers can help mitigate the impact of injected scripts by restricting script execution sources. Regular security audits of WordPress plugins and monitoring for unusual admin activity are recommended. Finally, disabling or removing unused plugins reduces the attack surface.
Description
The Product Enquiry for WooCommerce WordPress plugin before 3.2 does not sanitise and escape the page parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting which could be used against high privilege users such as admin