CVE-2023-7332: pmmp PocketMine-MP · Improper Validation of Specified Quantity in Input
Affects pmmp PocketMine-MPSource CVE Database V5
Not known to be exploited · CVSS 7.1 High : upgrade to 4.18.1 soon.
Data as of 26 Oct 2026, 14:05 UTC
- EPSS
- 0.3% chance of exploitation in 30 days – higher than 33% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 4.18.1
CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:NExploitation evidence
Disclosed: evidence found.
CVE published 31 Dec 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade pmmp/PocketMine-MP to 4.18.1.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
GitHubpmmp/PocketMine-MPpkg:github/pmmp/PocketMine-MPOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
The primary mitigation is to upgrade PocketMine-MP to version 4.18.1 or later, where the vulnerability has been addressed. If immediate upgrading is not feasible, server administrators should implement strict input validation on inventory transaction requests, ensuring that the quantity of items requested to be dropped does not exceed the actual items available in the player's hotbar. Monitoring server logs for unusual inventory transaction patterns can help detect exploitation attempts early. Rate limiting inventory transaction requests per player session may reduce the risk of repeated exploitation attempts. Additionally, applying network-level protections such as firewall rules to restrict access to the server to trusted IP ranges or implementing player authentication mechanisms can reduce exposure. Server operators should also educate their player communities about the risks of malicious behavior and encourage reporting of suspicious activities. Regular backups of server state can aid in recovery if crashes occur.
Description
PocketMine-MP versions prior to 4.18.1 contain an improper input validation vulnerability in inventory transaction handling. A remote attacker with a valid player session can request that the server drop more items than are available in the player's hotbar, triggering a server crash and resulting in denial of service.
References
- github.com/pmmp/PocketMine-MP/blob/4.18.1/changelogs/4.18.md (opens in a new tab)
- github.com/pmmp/PocketMine-MP/security/advisories/GHSA-h87r-f4vc-mchv (opens in a new tab)
- github.com/pmmp/PocketMine-MP/commit/5897476 (opens in a new tab)
- vulncheck.com/advisories/pocketmine-mp-improper-validation-of-dropped-item-count-allows-remote-server-crash (opens in a new tab)