CVE-2024-0241: encoded_id-rails · Uncontrolled Resource Consumption
Affects encoded_id-railsSource CVE Database V5
Not known to be exploited · CVSS 7.5 High : upgrade to 1.0.0.beta2 soon.
Data as of 26 Oct 2026, 10:12 UTC
- EPSS
- 1.1% chance of exploitation in 30 days – higher than 65% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 1.0.0.beta2
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:HExploitation evidence
Disclosed: evidence found.
CVE published 4 Jan 2024
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Upgrade encoded_id-rails to 1.0.0.beta2.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
RubyGemsencoded_id-railspkg:gem/encoded_id-railsOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
If you cannot patch yet, consider implementing request length limits or filtering on the "id" parameter at the application or web server level to mitigate potential exploitation.
Description
encoded_id-rails versions before 1.0.0.beta2 are affected by an uncontrolled resource consumption vulnerability. A remote and unauthenticated attacker might cause a denial of service condition by sending an HTTP request with an extremely long "id" parameter.
References
- github.com/stevegeek/encoded_id-rails/security/advisories/GHSA-3px7-jm2p-6h2c (opens in a new tab)
- github.com/stevegeek/encoded_id-rails/commit/afa495a77b8a21ad582611f9cdc2081dc4018b91 (opens in a new tab)
- github.com/advisories/GHSA-3px7-jm2p-6h2c (opens in a new tab)
- vulncheck.com/advisories/vc-advisory-GHSA-3px7-jm2p-6h2c (opens in a new tab)