CVE-2026-44193: opnsense core · Argument Injection
Affects opnsense coreSource CVE Database V5
Not known to be exploited · CVSS 9.1 Critical : upgrade to 26.1.7 as a priority.
Data as of 29 Oct 2026, 19:04 UTC
- EPSS
- 0.6% chance of exploitation in 30 days – higher than 52% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 26.1.7
CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 13 May 2026
Detectable: no evidence on record.
No public nuclei template indexed
Weaponized: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 29 Oct 2026.
What to do
Upgrade core and opnsense/core to 26.1.7.
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| opnsensecore | Affected
| Fixed in
|
GitHubopnsense/corepkg:github/opnsense/coreOther threats | Affected
| Fixed in
|
Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.
AI-suggested
Upgrade OPNsense core to version 26.1.7 or later, where this vulnerability is fixed. Patch status is confirmed by the vendor stating the fix is included in 26.1.7. No other mitigation is indicated.
Description
OPNsense is a FreeBSD based firewall and routing platform. Prior to 26.1.7, the XMLRPC method opnsense.restore_config_section fails to sanitize user supplied input leading to Remote Code Execution. This vulnerability is fixed in 26.1.7.