Skip to main content
CVE-2024-11233VulnerabilityPublished Updated

CVE-2024-11233: PHP · Heap-based Buffer Overflow

Affects PHPSource CVE Database V5

0

Not known to be exploited · CVSS 4.8 High · fixed in 8.3.14 : patch PHP soon.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
4.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
1.6% chance of exploitation in 30 days – higher than 75% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.14, 8.2.26, 8.1.31
CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:N/A:L

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade php/php-src to 8.3.14, 8.2.26 or 8.1.31.

Affected software

ProductAffectedFixed in
GitHubphp/php-srcpkg:github/php/php-srcOther threatsAffected
  • >=8.1.0 <8.1.31
  • >=8.2.0 <8.2.26
  • >=8.3.0 <8.3.14
Fixed in
  • 8.1.31
  • 8.2.26
  • 8.3.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

1. Upgrade PHP installations to versions 8.1.31, 8.2.26, or 8.3.14 as soon as these patches are officially released by the PHP Group. 2. If you cannot patch yet, implement input validation and sanitization on all quoted-printable encoded data inputs to reduce the risk of malicious payloads triggering the vulnerability. 3. Employ Web Application Firewalls (WAFs) with rules to detect and block suspicious quoted-printable encoded payloads. 4. Monitor application logs and crash reports for anomalies related to quoted-printable decoding failures or unexpected PHP process terminations. 5. Conduct code reviews and security testing on custom PHP modules or extensions that handle quoted-printable data. 6. Isolate critical PHP services and limit exposure to untrusted networks to reduce attack surface. 7. Maintain regular backups and incident response plans to quickly recover from potential denial-of-service incidents. 8. Stay informed via official PHP security advisories for patch releases and additional guidance.

Description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, due to an error in convert.quoted-printable-decode filter certain data can lead to buffer overread by one byte, which can in certain circumstances lead to crashes or disclose content of other memory areas.

References

Community reviews

Loading reviews…