Skip to main content
CVE-2024-11236VulnerabilityPublished Updated

CVE-2024-11236: PHP · Out-of-bounds Write

Affects PHPSource CVE Database V5

0

Not known to be exploited · CVSS 9.8 Critical · fixed in 8.3.14 : patch PHP as a priority.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
9.8Critical
How severe the flaw is on the 0–10 CVSS scale.
EPSS
2.0% chance of exploitation in 30 days – higher than 81% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 8.3.14, 8.2.26, 8.1.31
CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 27 Nov 2024

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Upgrade php/php-src to 8.3.14, 8.2.26 or 8.1.31.

Affected software

ProductAffectedFixed in
GitHubphp/php-srcpkg:github/php/php-srcOther threatsAffected
  • >=8.1.0 <8.1.31
  • >=8.2.0 <8.2.26
  • >=8.3.0 <8.3.14
Fixed in
  • 8.1.31
  • 8.2.26
  • 8.3.14

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

European organizations should take the following specific actions: 1) Immediately inventory all PHP deployments to identify versions 8.1.*, 8.2.*, and 8.3.* running on 32-bit systems. 3) For environments where immediate patching is not feasible, implement network-level restrictions to limit access to vulnerable services, especially those handling LDAP queries. 4) Audit application code to minimize use of ldap_escape() with untrusted input or implement additional input validation and length checks before passing data to this function. 5) Employ runtime memory protection mechanisms such as Address Space Layout Randomization (ASLR) and Data Execution Prevention (DEP) to reduce exploitation success. 6) Monitor logs and network traffic for unusual LDAP-related activity or crashes that may indicate exploitation attempts. 7) Engage with hosting providers and third-party vendors to ensure their PHP environments are patched. 8) Educate development and operations teams about the risks of integer overflows and memory corruption vulnerabilities in critical libraries. These targeted steps go beyond generic patching advice by focusing on risk reduction in LDAP input handling and legacy 32-bit environments.

Description

In PHP versions 8.1.* before 8.1.31, 8.2.* before 8.2.26, 8.3.* before 8.3.14, uncontrolled long string inputs to ldap_escape() function on 32-bit systems can cause an integer overflow, resulting in an out-of-bounds write.

References

Community reviews

Loading reviews…