Skip to main content
CVE-2024-11300VulnerabilityPublished Updated

CVE-2024-11300: lunary-ai/lunary · Insecure Direct Object Reference

Affects lunary-ai/lunarySource CVE Database V5

0

Not known to be exploited · CVSS 8.8 High : upgrade to 1.6.3 soon.

Data as of 26 Oct 2026, 08:30 UTC

CVSS 3.0 base score
8.8High
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.7% chance of exploitation in 30 days – higher than 53% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available – fixed in 1.6.3
CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 20 Mar 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.

What to do

Upgrade lunary-ai/lunary to 1.6.3.

Affected software

ProductAffectedFixed in
GitHublunary-ai/lunarypkg:github/lunary-ai/lunaryOther threatsAffected
  • <1.6.3
Fixed in
  • 1.6.3

Check your own hosts for these packages with threat-finder (opens in a new tab), our free open-source scanner.

AI-suggested

Organizations should immediately upgrade lunary-ai/lunary to version 1.6.3 or later where the vulnerability is fixed. Until patching is possible, implement strict access control checks at the application layer to validate user permissions against requested resources, ensuring that user-controlled keys cannot be used to access unauthorized data. Employ robust logging and monitoring of access patterns to detect anomalous requests that may indicate exploitation attempts. Use network segmentation and least privilege principles to limit exposure of the lunary-ai/lunary service. Conduct regular security assessments and code reviews focusing on authorization logic. Additionally, consider implementing Web Application Firewalls (WAFs) with custom rules to block suspicious URL patterns. Educate developers and administrators about the risks of CWE-639 to prevent similar issues in future development.

Description

In lunary-ai/lunary before version 1.6.3, an improper access control vulnerability exists where a user can access prompt data of another user. This issue affects version 1.6.2 and the main branch. The vulnerability allows unauthorized users to view sensitive prompt data by accessing specific URLs, leading to potential exposure of critical information.

References

Community reviews

Loading reviews…