CVE-2024-12296: Apus Framework (WordPress plugin) · Missing Authorization
Affects Apus Framework (WordPress plugin)Source CVE Database V5
Not known to be exploited · CVSS 8.8 High · fixed in 2.4 : patch Apus Framework (WordPress plugin) soon.
Data as of 26 Oct 2026, 09:15 UTC
- EPSS
- 0.5% chance of exploitation in 30 days – higher than 43% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
- Patch
- Available – fixed in 2.4
CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:HExploitation evidence
Disclosed: evidence found.
CVE published 12 Feb 2025
Detectable: no evidence on record.
No public nuclei template indexed
Weaponised: no evidence on record.
No public exploit code indexed in Metasploit or Exploit-DB
Exploited in the wildExploited: no evidence on record.
Not in CISA KEV and no source reports exploitation
Observed by OffSeq MirageSeen by Mirage: no evidence on record.
No attack traffic recorded by OffSeq Mirage sensors
A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 26 Oct 2026.
What to do
Affected software
| Product | Affected | Fixed in |
|---|---|---|
| ApusTheme Apus Framework | Affected
| Fixed in– |
AI-suggested
The vulnerability was partially fixed in version 2.4, so upgrading to the latest version of the Apus Framework plugin is recommended if available. Until a full fix is confirmed, restrict user roles and monitor for unauthorized changes to site options. Avoid granting Subscriber-level users unnecessary access and disable user registration if not required.
Description
The Apus Framework plugin for WordPress is vulnerable to unauthorized modification of data that can lead to privilege escalation due to a missing capability check on the 'import_page_options' function in all versions up to, and including, 2.4. This makes it possible for authenticated attackers, with Subscriber-level access and above, to update arbitrary options on the WordPress site. This can be leveraged to update the default role for registration to administrator and enable user registration for attackers to gain administrative user access to a vulnerable site. NOTE: This vulnerability was partially fixed in version 2.4.