Skip to main content
CVE-2024-12403VulnerabilityPublished Updated

CVE-2024-12403: Awesome Responsive Photo Gallery (WordPress plugin) · Cross-site Scripting

Affects Awesome Responsive Photo Gallery (WordPress plugin)Source CVE Database V5

0

Not known to be exploited · CVSS 6.1 Medium · patch available : update Awesome Responsive Photo Gallery (WordPress plugin) when convenient.

Data as of 25 Oct 2026, 19:02 UTC

CVSS 3.1 base score
6.1Medium
How severe the flaw is on the 0–10 CVSS scale.
EPSS
0.3% chance of exploitation in 30 days – higher than 26% of CVEsExploit Prediction Scoring System: the likelihood attackers will use this flaw soon.
Patch
Available
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

Exploitation evidence

  1. Disclosed: evidence found.

    CVE published 15 Jan 2025

  2. Detectable: no evidence on record.

    No public nuclei template indexed

  3. Weaponised: no evidence on record.

    No public exploit code indexed in Metasploit or Exploit-DB

  4. Exploited in the wild: no evidence on record.

    Not in CISA KEV and no source reports exploitation

  5. Observed by OffSeq Mirage: no evidence on record.

    No attack traffic recorded by OffSeq Mirage sensors

A missing step is not evidence of safety. Sources: cve.org (opens in a new tab), the Metasploit, Exploit-DB and nuclei-templates index as of 2026-10-25.

What to do

Affected software

ProductAffectedFixed in
realwebcare Awesome Responsive Photo Gallery – Image & Video Lightbox GalleryAffected
  • =0
Fixed in–

AI-suggested

A patch is available for this vulnerability. Users of the Awesome Responsive Photo Gallery – Image & Video Lightbox Gallery plugin should update to the latest version beyond 1.0.5 to remediate this issue. No additional vendor advisory content is provided, so check the plugin's official update channels for the patch. Until patched, avoid clicking untrusted links containing the 'awsmgallery' parameter.

Description

The Image Gallery – Responsive Photo Gallery plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'awsmgallery' parameter in all versions up to, and including, 1.0.5 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

References

Community reviews

Loading reviews…